$re = '/^(?i)(?!administrator|root).+/m';
$str = 'Administrator
aDmInIsTrAtOr
Root
root
jsmith
JSmith
Any_Text_Really
Any_meta_char_%$#!_and_12345';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;