import Foundation
let pattern = #"^(?i)(?!administrator|root).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Administrator
aDmInIsTrAtOr
Root
root
jsmith
JSmith
Any_Text_Really
Any_meta_char_%$#!_and_12345
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)