using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i)(?!administrator|root).+";
string substitution = @"";
string input = @"Administrator
aDmInIsTrAtOr
Root
root
jsmith
JSmith
Any_Text_Really
Any_meta_char_%$#!_and_12345";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}