const regex = /^(?i)(?!administrator|root).+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i)(?!administrator|root).+', 'gm')
const str = `Administrator
aDmInIsTrAtOr
Root
root
jsmith
JSmith
Any_Text_Really
Any_meta_char_%\$#!_and_12345`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);