#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Ben.+(?:banana|apple)"
Local $sString = ""Ben likes bananas" would return positive" & @CRLF & _
"" & @CRLF & _
""Ben eats banana" would return positive" & @CRLF & _
"" & @CRLF & _
""Ben eats apples" would be positive" & @CRLF & _
"" & @CRLF & _
""Ben likes apple" would be positive" & @CRLF & _
"" & @CRLF & _
""Ben likes pears" would be negative because pears was not a specified term." & @CRLF & _
"" & @CRLF & _
""Tom likes apple" would be negative because Ben is not specified"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")