import Foundation
let pattern = #"Ben.+(?:banana|apple)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Ben likes bananas" would return positive
"Ben eats banana" would return positive
"Ben eats apples" would be positive
"Ben likes apple" would be positive
"Ben likes pears" would be negative because pears was not a specified term.
"Tom likes apple" would be negative because Ben is not specified
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)