using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Ben.+(?:banana|apple)";
string input = @"""Ben likes bananas"" would return positive
""Ben eats banana"" would return positive
""Ben eats apples"" would be positive
""Ben likes apple"" would be positive
""Ben likes pears"" would be negative because pears was not a specified term.
""Tom likes apple"" would be negative because Ben is not specified";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}