// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Ben.+(?:banana|apple)").unwrap();
let string = "\"Ben likes bananas\" would return positive
\"Ben eats banana\" would return positive
\"Ben eats apples\" would be positive
\"Ben likes apple\" would be positive
\"Ben likes pears\" would be negative because pears was not a specified term.
\"Tom likes apple\" would be negative because Ben is not specified";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}