import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Ben.+(?:banana|apple)";
final String string = "\"Ben likes bananas\" would return positive\n\n"
+ "\"Ben eats banana\" would return positive\n\n"
+ "\"Ben eats apples\" would be positive\n\n"
+ "\"Ben likes apple\" would be positive\n\n"
+ "\"Ben likes pears\" would be negative because pears was not a specified term.\n\n"
+ "\"Tom likes apple\" would be negative because Ben is not specified";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}