package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Ben.+(?:banana|apple)`)
var str = `"Ben likes bananas" would return positive
"Ben eats banana" would return positive
"Ben eats apples" would be positive
"Ben likes apple" would be positive
"Ben likes pears" would be negative because pears was not a specified term.
"Tom likes apple" would be negative because Ben is not specified`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}