re = /Ben.+(?:banana|apple)/m
str = '"Ben likes bananas" would return positive
"Ben eats banana" would return positive
"Ben eats apples" would be positive
"Ben likes apple" would be positive
"Ben likes pears" would be negative because pears was not a specified term.
"Tom likes apple" would be negative because Ben is not specified'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end