$re = '/Ben.+(?:banana|apple)/m';
$str = '"Ben likes bananas" would return positive
"Ben eats banana" would return positive
"Ben eats apples" would be positive
"Ben likes apple" would be positive
"Ben likes pears" would be negative because pears was not a specified term.
"Tom likes apple" would be negative because Ben is not specified';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);