use strict;
my $str = '"Ben likes bananas" would return positive
"Ben eats banana" would return positive
"Ben eats apples" would be positive
"Ben likes apple" would be positive
"Ben likes pears" would be negative because pears was not a specified term.
"Tom likes apple" would be negative because Ben is not specified';
my $regex = qr/Ben.+(?:banana|apple)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}