# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*//gm;t' <<< "foo a b c
foo b c a
foo a b
foo b
foo b b
foo a b
foo a b a"