# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*"
test_str = ("foo a b c\n"
"foo b c a\n"
"foo a b\n"
"foo b\n"
"foo b b\n"
"foo a b \n"
"foo a b a")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.