const regex = /foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('foo(?!(?: [abc])*( [abc])(?: [abc])*\\1)(?: [abc])*', 'gm')
const str = `foo a b c
foo b c a
foo a b
foo b
foo b b
foo a b
foo a b a`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);