#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*"
Local $sString = "foo a b c" & @CRLF & _
"foo b c a" & @CRLF & _
"foo a b" & @CRLF & _
"foo b" & @CRLF & _
"foo b b" & @CRLF & _
"foo a b " & @CRLF & _
"foo a b a"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)