using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*";
string substitution = @"";
string input = @"foo a b c
foo b c a
foo a b
foo b
foo b b
foo a b
foo a b a";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}