import Foundation
let pattern = #"foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo a b c
foo b c a
foo a b
foo b
foo b b
foo a b
foo a b a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)