import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "foo(?!(?: [abc])*( [abc])(?: [abc])*\\1)(?: [abc])*";
final String string = "foo a b c\n"
+ "foo b c a\n"
+ "foo a b\n"
+ "foo b\n"
+ "foo b b\n"
+ "foo a b \n"
+ "foo a b a";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}