$re = '/foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*/m';
$str = 'foo a b c
foo b c a
foo a b
foo b
foo b b
foo a b
foo a b a';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;