re = /foo(?!(?: [abc])*( [abc])(?: [abc])*\1)(?: [abc])*/m
str = 'foo a b c
foo b c a
foo a b
foo b
foo b b
foo a b
foo a b a'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result