use strict;
my $str = 'To be or not to be-that is the question';
my $regex = qr/(?:(?:(?>(.{1,5})(?:(?<=[^\S\r\n])[^\S\r\n]?|(?<=[,.;:!\/?])|(?=\r?\n|[-#%&*@_])|[^\S\r\n]))|(.{1,5}))(?:\r?\n)?|(?:\r?\n))/p;
my $subst = '$1$2\\r\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";