$re = '/(?:(?:(?>(.{1,5})(?:(?<=[^\S\r\n])[^\S\r\n]?|(?<=[,.;:!\/?])|(?=\r?\n|[-#%&*@_])|[^\S\r\n]))|(.{1,5}))(?:\r?\n)?|(?:\r?\n))/';
$str = 'To be or not to be-that is the question';
$subst = "$1$2\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;