re = /(?:(?:(?>(.{1,5})(?:(?<=[^\S\r\n])[^\S\r\n]?|(?<=[,.;:!\/?])|(?=\r?\n|[-#%&*@_])|[^\S\r\n]))|(.{1,5}))(?:\r?\n)?|(?:\r?\n))/
str = 'To be or not to be-that is the question'
subst = '$1$2\\r\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result