import Foundation
let pattern = ##"(?:(?:(?>(.{1,5})(?:(?<=[^\S\r\n])[^\S\r\n]?|(?<=[,.;:!\/?])|(?=\r?\n|[-#%&*@_])|[^\S\r\n]))|(.{1,5}))(?:\r?\n)?|(?:\r?\n))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"To be or not to be-that is the question"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2\r\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)