# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*/$2/g;t' <<< ":1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:"