import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(:hello\\[((\\w*)|(\\d*,){3}|(\\w|\\ |.|\\?)*)]:).*";
final String string = ":1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}