const regex = /.*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(:hello\\[((\\w*)|(\\d*,){3}|(\\w|\\ |.|\\?)*)]:).*', 'g')
const str = `:1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);