import Foundation
let pattern = #".*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #":1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)