use strict;
my $str = ':1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:';
my $regex = qr/.*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";