$re = '/.*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*/';
$str = ':1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;