package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*`)
var str = `:1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}