# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*"
test_str = ":1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:"
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.