#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*(:hello\[((\w*)|(\d*,){3}|(\w|\ |.|\?)*)]:).*"
Local $sString = ":1[hello]:2[300]:homebase[0,14,88,]:hello[I made a solution.]:"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)