# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/(pdf)\\//\\\/$1\\\//g;t' <<< "assets/pdf/regulamento_demais_ddds_ Oi Mod.pdf"