re = /\/(pdf)\//
str = 'assets/pdf/regulamento_demais_ddds_ Oi Mod.pdf'
subst = '\\\\/$1\\\\/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result