import Foundation
let pattern = #"\/(pdf)\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"assets/pdf/regulamento_demais_ddds_ Oi Mod.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\/$1\\/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)