use strict;
my $str = 'assets/pdf/regulamento_demais_ddds_ Oi Mod.pdf';
my $regex = qr/\/(pdf)\//p;
my $subst = '\\\\/$1\\\\/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";