const regex = /\/(pdf)\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(pdf)\\\/', 'g')
const str = `assets/pdf/regulamento_demais_ddds_ Oi Mod.pdf`;
const subst = `\\/$1\\/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);