$re = '/\/(pdf)\//';
$str = 'assets/pdf/regulamento_demais_ddds_ Oi Mod.pdf';
$subst = "\\/$1\\/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;