# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})/First match:\n$1\n\nSecond match:\n$3/g;t' <<< "@if(topLevel)
{{
<form method=\"post\">
@if(bottomLevel)
{{
<input>
}}
</form>
}}"