package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})`)
var str = `@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}`
var substitution = "First match:\n$1\n\nSecond match:\n$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}