#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})"
Local $sString = "@if(topLevel)" & @CRLF & _
"{{" & @CRLF & _
" <form method="post">" & @CRLF & _
" @if(bottomLevel)" & @CRLF & _
" {{" & @CRLF & _
" <input>" & @CRLF & _
" }}" & @CRLF & _
" </form>" & @CRLF & _
"}}"
Local $sSubst = "First match:\n$1\n\nSecond match:\n$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)