const regex = /@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@if\\((.*?)\\)\\s+({{\\s+((?:[^{}]|(?2))*?)\\s+}})', 'g')
const str = `@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}`;
const subst = `First match:\n$1\n\nSecond match:\n$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);