import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@if\\((.*?)\\)\\s+(\\{\\{\\s+((?:[^\\{\\}]|(?2))*?)\\s+\\}\\})";
final String string = "@if(topLevel)\n"
+ "{{\n"
+ " <form method=\"post\">\n"
+ " @if(bottomLevel)\n"
+ " {{\n"
+ " <input>\n"
+ " }}\n"
+ " </form>\n"
+ "}}";
final String subst = "First match:\\n$1\\n\\nSecond match:\\n$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}