re = /@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})/
str = '@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}'
subst = 'First match:\\n$1\\n\\nSecond match:\\n$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result