using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})";
string substitution = @"First match:\n$1\n\nSecond match:\n$3";
string input = @"@if(topLevel)
{{
<form method=""post"">
@if(bottomLevel)
{{
<input>
}}
</form>
}}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}