$re = '/@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})/';
$str = '@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}';
$subst = "First match:\n$1\n\nSecond match:\n$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;