use strict;
my $str = '@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}';
my $regex = qr/@if\((.*?)\)\s+({{\s+((?:[^{}]|(?2))*?)\s+}})/p;
my $subst = 'First match:\\n$1\\n\\nSecond match:\\n$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";